5.3Composer.json文件的讲解

依赖属性

1.require

运行或部署当前项目所依赖的包。

2.require-dev

开发或测试当前项目所依赖的包。

版本属性

1.确切版本

您可以指定包的确切版本。这将告诉 Composer 安装这个版本。

1.0.2

2.运算符版本范围

通过使用比较运算符,您可以指定有效版本的范围。有效的运算符是>>=<<=!=

您可以定义多个范围。由空格 (  ) 或逗号 ( ,)分隔的范围将被视为逻辑 AND。双管道 ( ||) 将被视为逻辑 OR。AND 的优先级高于 OR。

>=1.0
>=1.0 <2.0
>=1.0 <1.1 || >=1.2

3.带连字符的版本范围 (-)

//相当于>=1.0.0 <2.1(2.0变2.0.*)
1.0 - 2.0

//相当于>=1.0.0 <=2.1.0
1.0.0 - 2.1.0

4.通配符版本范围 (.*)

//相当于>=1.0 <1.1
1.0.*

5.波浪号版本范围 (~)

大于等于您所指定的版本,小于最右边的非0数字的前面的数字加1。

//相当于>=1.2 <2.0.0
~1.2

//相当于>=1.2.3 <1.3.0
~1.2.3

6.插入符号版本范围 (^)

大于等于您所指定的版本,小于最左边的非0数字加1。

//相当于>=1.2.0 <2.0.0
^1.2

//相当于>=1.2.3 <2.0.0
^1.2.3

//相当于>=0.3.0 <0.4.0
^0.3

7.稳定性约束

如果您使用的约束未明确定义稳定性,则 Composer 将在内部默认为-dev-stable,具体取决于所使用的运算符。

如果您希望在比较中仅明确考虑稳定版本,请添加后缀-stable

约束内部
1.2.3=1.2.3.0-stable
>1.2>1.2.0.0-stable
>=1.2>=1.2.0.0-dev
>=1.2-stable>=1.2.0.0-stable
<1.3<1.3.0.0-dev
<=1.3<=1.3.0.0-stable
1 - 2>=1.0.0.0-dev <3.0.0.0-dev
~1.3>=1.3.0.0-dev <2.0.0.0-dev
1.4.*>=1.4.0.0-dev <1.5.0.0-dev

原创文章,作者:huoxiaoqiang,如若转载,请注明出处:https://www.huoxiaoqiang.com/back/php/5376.html

发表评论

登录后才能评论